차이

문서의 선택한 두 판 사이의 차이를 보여줍니다.

차이 보기로 링크

양쪽 이전 판 이전 판
redmine_-_레드마인 [2019/07/05 11:41]
koov
redmine_-_레드마인 [2019/07/05 11:42] (현재)
koov [Debian/Ubuntu에서 redmine 패키지 설치중 Could not find gem 'mysql2 (~> 0.4.0)' in any of the gem sources listed in your Gemfile or available on this machine. 오류 발생시]
줄 6: 줄 6:
 ===== Tip & Tech ===== ===== Tip & Tech =====
 ==== Debian/​Ubuntu에서 redmine 패키지 설치중 Could not find gem '​mysql2 (~> 0.4.0)'​ in any of the gem sources listed in your Gemfile or available on this machine. 오류 발생시 ==== ==== Debian/​Ubuntu에서 redmine 패키지 설치중 Could not find gem '​mysql2 (~> 0.4.0)'​ in any of the gem sources listed in your Gemfile or available on this machine. 오류 발생시 ====
 +
 +<WRAP prewrap>
 +<code bash>
 +Creating config file /​etc/​redmine/​default/​database.yml with new version
 +checking privileges on database redmine_default for redmine/​instance@localhost:​ user creation needed.
 +granting access to database redmine_default for redmine/​instance@localhost:​ success.
 +verifying access for redmine/​instance@localhost:​ success.
 +creating database redmine_default:​ success.
 +verifying database redmine_default exists: success.
 +dbconfig-common:​ flushing administrative password
 +Could not find gem '​mysql2 (~> 0.4.0)'​ in any of the gem sources listed in your Gemfile or available on this machine.
 +Run `bundle install` to install missing gems.
 +dpkg: error processing package redmine (--configure):​
 + ​설치한 post-installation 스크립트 하위 프로세스가 오류 7번을 리턴했습니다
 +ruby-sass-rails (5.0.6-1) 설정하는 중입니다 ...
 +ruby-web-console (2.2.1-2) 설정하는 중입니다 ...
 +ruby-turbolinks (2.5.3-3) 설정하는 중입니다 ...
 +Processing triggers for libc-bin (2.24-11+deb9u4) ...
 +처리하는데 오류가 발생했습니다:​
 + ​redmine
 +E: Sub-process /​usr/​bin/​dpkg returned an error code (1)
 +</​code>​
 +</​WRAP>​
 +
  
 해당 오류는 ''​ruby-mysql2''​패키지가 의존성에서 빠져서 생기는 오류임. 단순히 해당 패키지만 설치해주면 해결된다. 해당 오류는 ''​ruby-mysql2''​패키지가 의존성에서 빠져서 생기는 오류임. 단순히 해당 패키지만 설치해주면 해결된다.
  • redmine_-_레드마인.txt
  • 마지막으로 수정됨: 2019/07/05 11:42
  • 저자 koov